Apache Solr < 8.4.0 Remote Code Execution

medium Web Application Scanning Plugin ID 98924

Synopsis

Apache Solr < 8.4.0 Remote Code Execution

Description

Apache Solr versions 5.0.0 to 8.3.1 allow for a a remote, unauthenticated user to set 'params.resource.loader.enabled' to true via an HTTP POST request to the JMX server. Enabling this parameter would allow an attacker to use the velocity template parameter in a specially crafted Solr request, leading to Remote Code Execution (RCE).

Solution

Upgrade to Apache Solr version 8.4.0 or later

See Also

https://www.tenable.com/blog/cve-2019-17558-apache-solr-vulnerable-to-remote-code-execution-zero-day-vulnerability

https://issues.apache.org/jira/browse/SOLR-13971

https://issues.apache.org/jira/browse/SOLR-14025

Plugin Details

Severity: Medium

ID: 98924

Type: remote

Published: 1/24/2020

Updated: 5/22/2020

Scan Template: api, scan, pci

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6

Vector: AV:N/AC:M/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:apache:solr:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 12/29/2019

Vulnerability Publication Date: 10/29/2019

Reference Information

CVE: CVE-2019-17558