Apache 2.4.17 / 2.4.18 mod_http2 Denial of Service

Medium Web Application Scanning Plugin ID 98917

Synopsis

Apache 2.4.17 / 2.4.18 mod_http2 Denial of Service

Description

According to its banner, the version of Apache running on the remote host is either 2.4.17 or 2.4.18. It is, therefore, affected by a denial of service vulnerability in the module for the HTTP/2 protocol due to thread starvation.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.20 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.20

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.20

Plugin Details

Severity: Medium

ID: 98917

Type: remote

Published: 2019/01/31

Updated: 2019/04/10

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2016/04/11

Vulnerability Publication Date: 2016/04/11

Reference Information

CVE: CVE-2016-1546

BID: 92331