Apache 2.4.x < 2.4.35 Denial of Service

medium Web Application Scanning Plugin ID 98916
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Apache 2.4.x < 2.4.35 Denial of Service

Description

According to its banner, the version of Apache running on the remote host is 2.4.x prior to 2.4.35. By sending continuous SETTINGS frames of maximum size an ongoing HTTP/2 connection could be kept busy and would never time out. This can be abused for a DoS on the server. This only affect a server that has enabled the h2 protocol.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.35 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.35

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.35

Plugin Details

Severity: Medium

ID: 98916

Type: remote

Published: 1/31/2019

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 9/25/2018

Vulnerability Publication Date: 9/25/2018

Reference Information

CVE: CVE-2018-11763

CWE: 400

WASC: Denial of Service

OWASP: 2013-A9, 2017-A9

OWASP API: 2019-API7