Apache 2.4.x < 2.4.28 HTTP Vulnerability (OptionsBleed)

high Web Application Scanning Plugin ID 98913
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Apache 2.4.x < 2.4.28 HTTP Vulnerability (OptionsBleed)

Description

According to its banner, the version of Apache running on the remote host is 2.4.x prior to 2.4.28. It is, therefore, affected by an HTTP vulnerability related to the <Limit {method}> directive in an .htaccess file.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.28 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.28

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.28

Plugin Details

Severity: High

ID: 98913

Type: remote

Published: 1/9/2019

Updated: 10/7/2021

Scan Template: scan, pci, api

Risk Information

CVSS Score Source: CVE-2017-9798

CVSS v2

Risk Factor: Medium

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3

Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/18/2017

Vulnerability Publication Date: 9/18/2017

Reference Information

CVE: CVE-2017-9798