Apache 2.4.x < 2.4.27 Multiple Vulnerabilities

Medium Web Application Scanning Plugin ID 98912

Synopsis

Apache 2.4.x < 2.4.27 Multiple Vulnerabilities

Description

According to its banner, the version of Apache running on the remote host is 2.4.x prior to 2.4.27. It is, therefore, affected by the following vulnerabilities :

- A denial of service vulnerability exists in httpd due to a failure to initialize or reset the value placeholder in [Proxy-]Authorization headers of type 'Digest' before or between successive key=value assignments by mod_auth_digest. An unauthenticated, remote attacker can exploit this, by providing an initial key with no '=' assignment, to disclose sensitive information or cause a denial of service condition. (CVE-2017-9788)

- A read-after-free error exists in httpd that is triggered when closing a large number of connections. An unauthenticated, remote attacker can exploit this to have an unspecified impact. (CVE-2017-9789)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.27 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.27

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.27

Plugin Details

Severity: Medium

ID: 98912

Type: remote

Published: 2019/01/09

Updated: 2020/02/18

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

CVSS v3.0

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2017/07/11

Vulnerability Publication Date: 2017/07/11

Reference Information

CVE: CVE-2017-9788, CVE-2017-9789

BID: 99568, 99569

CWE: 20, 416

WASC: Improper Input Handling

OWASP: 2010-A4, 2013-A4, 2013-A9, 2017-A5, 2017-A9