Apache 2.4.x < 2.4.27 Multiple Vulnerabilities

critical Web Application Scanning Plugin ID 98912



Apache 2.4.x < 2.4.27 Multiple Vulnerabilities


According to its banner, the version of Apache running on the remote host is 2.4.x prior to 2.4.27. It is, therefore, affected by the following vulnerabilities :

- A denial of service vulnerability exists in httpd due to a failure to initialize or reset the value placeholder in [Proxy-]Authorization headers of type 'Digest' before or between successive key=value assignments by mod_auth_digest. An unauthenticated, remote attacker can exploit this, by providing an initial key with no '=' assignment, to disclose sensitive information or cause a denial of service condition. (CVE-2017-9788)

- A read-after-free error exists in httpd that is triggered when closing a large number of connections. An unauthenticated, remote attacker can exploit this to have an unspecified impact. (CVE-2017-9789)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache version 2.4.27 or later.

See Also



Plugin Details

Severity: Critical

ID: 98912

Type: remote

Published: 1/9/2019

Updated: 10/26/2022

Scan Template: pci, api, scan

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Medium

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

CVSS Score Source: CVE-2017-9788


Risk Factor: Critical

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

CVSS Score Source: CVE-2017-9788

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 7/13/2017

Vulnerability Publication Date: 7/13/2017

Reference Information

CVE: CVE-2017-9789, CVE-2017-9788