Apache 2.4.x < 2.4.9 Multiple Vulnerabilities

Medium Web Application Scanning Plugin ID 98905

Synopsis

Apache 2.4.x < 2.4.9 Multiple Vulnerabilities

Description

According to its banner, the version of Apache 2.4.x running on the remote host is a version prior to 2.4.9. It is, therefore, affected by the following vulnerabilities :

- A flaw exists with the 'mod_dav' module that is caused when tracking the length of CDATA that has leading white space. A remote attacker with a specially crafted DAV WRITE request can cause the service to stop responding. (CVE-2013-6438)

- A flaw exists in 'mod_log_config' module that is caused when logging a cookie that has an unassigned value. A remote attacker with a specially crafted request can cause the service to crash. (CVE-2014-0098)

Note that the scanner did not actually test for these issues, but instead has relied on the version in the server's banner.

Solution

Upgrade to Apache version 2.4.9 or later. Alternatively, ensure that the affected modules are not in use.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.9

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.9

Plugin Details

Severity: Medium

ID: 98905

Type: remote

Published: 2019/01/09

Updated: 2019/04/10

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2014/03/18

Vulnerability Publication Date: 2014/03/18

Reference Information

CVE: CVE-2013-6438, CVE-2014-0098

BID: 66303