Apache 2.4.6 Remote DoS

high Web Application Scanning Plugin ID 98904
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Apache 2.4.6 Remote DoS

Description

According to its banner, the version of Apache 2.4.x running on the remote host is version 2.4.6. It is, therefore, affected by a flaw in the mod_cache module involving a NULL pointer dereference. An attacker may be able to specially craft a request designed to cause a denial of service.

Note that the scanner has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.7 or later. Alternatively, ensure that the affected module is not in use.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.7

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.7

Plugin Details

Severity: High

ID: 98904

Type: remote

Published: 1/9/2019

Updated: 7/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3

Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 7/20/2014

Vulnerability Publication Date: 7/20/2014

Reference Information

CVE: CVE-2013-4352

CWE: 476

OWASP: 2013-A9, 2017-A9

OWASP API: 2019-API7