Apache 2.4.x < 2.4.6 Multiple Vulnerabilities

high Web Application Scanning Plugin ID 98903

Synopsis

Apache 2.4.x < 2.4.6 Multiple Vulnerabilities

Description

According to its banner, the version of Apache 2.4.x running on the remote host is prior to 2.4.6. It is, therefore, potentially affected by the following vulnerabilities :

- A denial of service vulnerability exists relating to the 'mod_dav' module as it relates to MERGE requests. (CVE-2013-1896)

- An error exists related to the 'mod_session_dbd' module, flags and session-saving having an unspecified impact. (CVE-2013-2249)

Note that the scanner did not actually test for these issues, but instead has relied on the version in the server's banner.

Solution

Upgrade to Apache version 2.4.6 or later. Alternatively, ensure that the affected modules are not in use.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.6

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.6

Plugin Details

Severity: High

ID: 98903

Type: remote

Published: 1/9/2019

Updated: 3/5/2021

Scan Template: api, scan, pci

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 7/10/2013

Vulnerability Publication Date: 7/10/2013

Reference Information

CVE: CVE-2013-1896, CVE-2013-2249