Apache 2.4.x < 2.4.3 Multiple Vulnerabilities

Medium Web Application Scanning Plugin ID 98901

Synopsis

Apache 2.4.x < 2.4.3 Multiple Vulnerabilities

Description

According to its banner, the version of Apache 2.4.x running on the remote host is prior 2.4.3. It is, therefore, affected by the following vulnerabilities :

- An input validation error exists related to 'mod_negotiation', 'Multiviews' and untrusted uploads that can allow cross-site scripting attacks. (CVE-2012-2687)

- An error exists related to 'mod_proxy_ajp' and 'mod_proxy_http' that can allow connections to remain open. This condition can allow information disclosure when combined with specially crafted requests. (CVE-2012-3502)

Note that the scanner did not actually test for these issues, but instead has relied on the version in the server's banner.

Solution

Upgrade to Apache version 2.4.3 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.3

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.3

https://issues.apache.org/bugzilla/show_bug.cgi?id=53727

Plugin Details

Severity: Medium

ID: 98901

Type: remote

Published: 2019/01/09

Updated: 2020/02/19

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2012/08/21

Vulnerability Publication Date: 2012/06/13

Reference Information

CVE: CVE-2012-2687, CVE-2012-3502, CVE-2008-0455

BID: 27409, 55131