PHP 7.2.x < 7.2.4 Dumpable FPM Child Processes

Low Web Application Scanning Plugin ID 98867

Synopsis

PHP 7.2.x < 7.2.4 Dumpable FPM Child Processes

Description

According to its banner, the version of PHP running on the remote web server is 7.2.x prior to 7.2.4. It is, therefore, affected by opcache access controls bypass via dumpable FPM child processes.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.2.4 or later.

See Also

http://php.net/ChangeLog-7.php#7.2.4

Plugin Details

Severity: Low

ID: 98867

Type: remote

Published: 2019/01/09

Updated: 2019/04/10

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 1.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 4.7

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2018/03/29

Vulnerability Publication Date: 2018/03/29

Reference Information

CVE: CVE-2018-10545

BID: 104022

CWE: 200

WASC: Information Leakage

OWASP: 2010-A6, 2013-A5, 2013-A9, 2017-A6, 2017-A9