PHP 7.1.x < 7.1.15 Stack Buffer Overflow

high Web Application Scanning Plugin ID 98859

Synopsis

PHP 7.1.x < 7.1.15 Stack Buffer Overflow

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.15. It is, therefore, affected by a stack buffer overflow vulnerability.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.1.15 or later.

See Also

http://php.net/ChangeLog-7.php#7.1.15

https://www.cisecurity.org/advisory/multiple-vulnerabilities-in-php-could-allow-for-arbitrary-code-execution_2018-023/

Plugin Details

Severity: High

ID: 98859

Type: remote

Published: 1/9/2019

Updated: 3/5/2021

Scan Template: api, scan, pci

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 3/1/2018

Vulnerability Publication Date: 3/1/2018

Reference Information

CVE: CVE-2018-7584