PHP 7.0.x < 7.0.25 Multiple Vulnerabilities

High Web Application Scanning Plugin ID 98845


PHP 7.0.x < 7.0.25 Multiple Vulnerabilities


According to its banner, the version of PHP running on the remote web server is 7.0.x prior to 7.0.25. It is, therefore, affected by multiple vulnerabilities.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 7.0.25 or later.

See Also

Plugin Details

Severity: High

ID: 98845

Type: remote

Published: 2019/01/09

Updated: 2020/02/18

Scan Template: api, scan, pci

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2017/10/26

Vulnerability Publication Date: 2017/10/26

Reference Information

CVE: CVE-2016-1283, CVE-2017-16642

BID: 79825, 101745

CWE: 119, 125

WASC: Buffer Overflow

OWASP: 2013-A9, 2017-A9