PHP 5.6.x < 5.6.2 Multiple Vulnerabilities

High Web Application Scanning Plugin ID 98809

Synopsis

PHP 5.6.x < 5.6.2 Multiple Vulnerabilities

Description

According to its banner, the version of PHP 5.6.x installed on the remote host is prior to 5.6.2. It is, therefore, affected by the following vulnerabilities :

- A buffer overflow error exists in the function 'mkgmtime' that can allow application crashes or arbitrary code execution. (CVE-2014-3668)

- An integer overflow error exists in the function 'unserialize' that can allow denial of service attacks. Note that this only affects 32-bit instances. (CVE-2014-3669)

- A heap corruption error exists in the function 'exif_thumbnail' that can allow application crashes or arbitrary code execution. (CVE-2014-3670)

- An input-validation error exists in the cURL extension's file 'ext/curl/interface.c' and NULL option handling that can allow information disclosure. (Bug #68089)

Note that the scanner has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 5.6.2 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.6.2

Plugin Details

Severity: High

ID: 98809

Type: remote

Published: 2019/01/09

Updated: 2020/07/24

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2014/10/16

Vulnerability Publication Date: 2014/10/16

Reference Information

CVE: CVE-2014-3668, CVE-2014-3669, CVE-2014-3670

BID: 70611, 70665, 70666

CWE: 119, 189

WASC: Buffer Overflow

OWASP: 2013-A9, 2017-A9