vBulletin < 5.3.0 Server-Side Request Forgery Vulnerability

medium Web Application Scanning Plugin ID 98778

Synopsis

vBulletin < 5.3.0 Server-Side Request Forgery Vulnerability

Description

According to the self-reported version in its response header, the version of vBulletin hosted on the remote web server is < 5.3.0. It is, therefore, affected by a Server-Side Request Forgery (SSRF) vulnerability due to PHP parse_url function.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to vBulletin version 5.3.0 or later.

See Also

https://forum.vbulletin.com/forum/vbulletin-announcements/vbulletin-announcements_aa/4367744-vbulletin-5-3-0-connect-is-now-available

http://tracker.vbulletin.com/browse/VBV-17037

Plugin Details

Severity: Medium

ID: 98778

Type: remote

Published: 12/12/2019

Updated: 10/14/2020

Scan Template: api, scan, pci

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 8.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N

Vulnerability Information

CPE: cpe:2.3:a:vbulletin:vbulletin:*:*:*:*:*:*:*:*

Patch Publication Date: 4/4/2017

Vulnerability Publication Date: 4/4/2017

Reference Information

CVE: CVE-2017-7529