vBulletin < 5.3.0 Server-Side Request Forgery Vulnerability

Medium Web Application Scanning Plugin ID 98778


vBulletin < 5.3.0 Server-Side Request Forgery Vulnerability


According to the self-reported version in its response header, the version of vBulletin hosted on the remote web server is < 5.3.0. It is, therefore, affected by a Server-Side Request Forgery (SSRF) vulnerability due to PHP parse_url function.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to vBulletin version 5.3.0 or later.

See Also



Plugin Details

Severity: Medium

ID: 98778

Type: remote

Published: 2019/12/12

Updated: 2020/02/19

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:vbulletin:vbulletin:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2017/04/04

Vulnerability Publication Date: 2017/04/04

Reference Information

CVE: CVE-2017-7529

BID: 99534

CWE: 918

WASC: Application Misconfiguration

OWASP: 2010-A6, 2013-A5, 2013-A9, 2017-A6, 2017-A9