PHP 7.3.x < 7.3.11 Remote Code Execution Vulnerability

critical Web Application Scanning Plugin ID 98766
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

PHP 7.3.x < 7.3.11 Remote Code Execution Vulnerability

Description

According to its banner, the version of PHP running on the remote web server is prior to 7.1.33, 7.2.x prior to 7.2.24, or 7.3.x prior to 7.3.11. It is, therefore, affected by a remote code execution vulnerability due to insufficient validation of user input. An unauthenticated, remote attacker can exploit this, by sending a specially crafted request, to cause the execution of arbitrary code by breaking the fastcgi_split_path_info directive.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.3.11 or later.

See Also

https://www.php.net/ChangeLog-7.php#7.3.11

https://www.php.net/index.php#2019-10-24-2

Plugin Details

Severity: Critical

ID: 98766

Type: remote

Published: 10/30/2019

Updated: 10/11/2021

Scan Template: scan, pci, api

Risk Information

CVSS Score Source: CVE-2019-11043

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/24/2019

Vulnerability Publication Date: 10/24/2019

Reference Information

CVE: CVE-2019-11043