Blog2Social Plugin for WordPress < 5.6.0 SQL Injection

critical Web Application Scanning Plugin ID 98712

Language:

Synopsis

Blog2Social Plugin for WordPress < 5.6.0 SQL Injection

Description

The WordPress Blog2Social Plugin installed on the remote host is affected by a SQL injection vulnerability due to improper sanitization of user-supplied input. A remote attacker can exploit this issue to manipulate SQL queries, resulting in the disclosure of sensitive information and modification of data.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Blog2Social Plugin for WordPress 5.6.0 or latest.

See Also

https://fortiguard.com/zeroday/FG-VD-19-094

https://wordpress.org/plugins/blog2social/

Plugin Details

Severity: Critical

ID: 98712

Type: remote

Published: 9/24/2019

Updated: 10/7/2021

Scan Template: pci, scan

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2019-13572

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2019-13572

Vulnerability Information

CPE: cpe:2.3:a:adenion:blog2social:*:*:*:*:*:wordpress:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 8/1/2019

Vulnerability Publication Date: 8/1/2019

Reference Information

CVE: CVE-2019-13572