Nginx 1.9.5 < 1.16.1 Multiple Vulnerabilties

high Web Application Scanning Plugin ID 98668

Synopsis

Nginx 1.9.5 < 1.16.1 Multiple Vulnerabilties

Description

According to its Server response header, the installed version of nginx is 1.9.5 to 1.16.0 or 1.17.x prior to 1.17.3. It is, therefore, affected by the following issues :

- An excessive CPU usage in HTTP/2 with small window updates exists related to the module 'ngx_http_v2_module'. (CVE-2019-9511)

- An excessive CPU usage in HTTP/2 with priority changes exists related to the module 'ngx_http_v2_module'. (CVE-2019-9513)

- An excessive CPU usage in HTTP/2 with zero length headers exists related to the module 'ngx_http_v2_module'. (CVE-2019-9516)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to nginx version 1.16.1 or later.

See Also

http://mailman.nginx.org/pipermail/nginx-announce/2019/000249.html

Plugin Details

Severity: High

ID: 98668

Type: remote

Published: 8/20/2019

Updated: 10/7/2021

Scan Template: scan, pci, api

Risk Information

CVSS Score Source: CVE-2019-9511

CVSS v2

Risk Factor: High

Base Score: 7.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:a:nginx:nginx:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 8/13/2019

Vulnerability Publication Date: 8/13/2019

Reference Information

CVE: CVE-2019-9511, CVE-2019-9513, CVE-2019-9516