Atlassian Crowd 3.4.x < 3.4.4 RCE Vulnerability

High Web Application Scanning Plugin ID 98656

Synopsis

Atlassian Crowd 3.4.x < 3.4.4 RCE Vulnerability

Description

According to its self-reported version number, the Atlassian Crowd application running on the remote host is 2.1.x prior to 3.0.5, 3.1.x prior to 3.1.6, 3.2.x prior to 3.2.8, 3.3.x prior to 3.3.5 or 3.4.x prior to 3.4.4. It is, therefore, affected by a remote code execution (RCE) vulnerability. An unauthenticated, remote attacker can exploit this, by using pdkinstall development plugin, to install arbitrary plugins, which permits remote code execution.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Atlassian Crowd version 3.4.4 or later.

See Also

https://confluence.atlassian.com/crowd/crowd-security-advisory-2019-05-22-970260700.html

Plugin Details

Severity: High

ID: 98656

Type: remote

Published: 2019/08/13

Updated: 2019/08/13

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:atlassian:crowd:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2019/05/22

Vulnerability Publication Date: 2019/05/22

Reference Information

CVE: CVE-2019-11580

BID: 108637

CWE: 20

WASC: Improper Input Handling

OWASP: 2010-A4, 2013-A4, 2013-A9, 2017-A5, 2017-A9