PHP 7.2.x < 7.2.19 Multiple Vulnerabilities

Medium Web Application Scanning Plugin ID 98620

Synopsis

PHP 7.2.x < 7.2.19 Multiple Vulnerabilities

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.30, 7.2.x prior to 7.2.19 or 7.3.x prior to 7.3.6. It is, therefore, affected by the following vulnerabilities:

- An uninitialized read vulnerability exists in gdImageCreateFromXbm due to sscanf method not being able to read a hex value. An attacker may be able exploit this issue, to cause the disclose of sensitive information. (CVE-2019-11038)

- An out of bounds read vulnerability exists in iconv.c:_php_iconv_mime_decode() due to integer overflow. An attacker may be able exploit this issue, to cause the disclose of sensitive information. (CVE-2019-11039)

- A heap-based buffer overflow condition exists on php_jpg_get16. An attacker can exploit this, to cause a denial of service condition or the execution of arbitrary code. (CVE-2019-11040)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.2.19 or later.

See Also

https://php.net/ChangeLog-7.php#7.2.19

https://www.php.net/index.php#id2019-05-30-2

Plugin Details

Severity: Medium

ID: 98620

Type: remote

Published: 2019/06/18

Updated: 2020/02/19

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

CVSS v3.0

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2019/05/30

Vulnerability Publication Date: 2019/05/30

Reference Information

CVE: CVE-2019-11038, CVE-2019-11039, CVE-2019-11040

BID: 108514, 108520, 108525

CWE: 122, 190

WASC: Buffer Overflow, Integer Overflows

OWASP: 2013-A9, 2017-A9