Drupal 8.6.x < 8.6.10 Remote Code Execution Vulnerability

high Web Application Scanning Plugin ID 98589
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Drupal 8.6.x < 8.6.10 Remote Code Execution Vulnerability

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 8.5.x prior to 8.5.11 or 8.6.x prior to 8.6.10. It is, therefore, affected by a remote code execution vulnerability due to improper sanitization of data from non-form sources.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to Drupal version 8.6.10 or latest.

See Also

https://www.drupal.org/sa-core-2019-003

https://www.drupal.org/project/drupal/releases/8.6.10

Plugin Details

Severity: High

ID: 98589

Type: remote

Published: 2/21/2019

Updated: 10/7/2021

Scan Template: scan, pci, api

Risk Information

CVSS Score Source: CVE-2019-6340

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: High

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 2/21/2019

Vulnerability Publication Date: 2/21/2019

Reference Information

CVE: CVE-2019-6340