Drupal 8.x < 8.3.4 Multiple Vulnerabilities

Critical Web Application Scanning Plugin ID 98558

Synopsis

Drupal 8.x < 8.3.4 Multiple Vulnerabilities

Description

According to its self-reported version number, the detected Drupal application is affected by multiple vulnerabilities :

- A flaw exists in the PECL YAML parser due to unsafe handling of PHP objects during certain operations. An unauthenticated, remote attacker can exploit this to execute arbitrary code. (CVE-2017-6920)

- A flaw exists in the file REST resource due to improper validation of user-supplied input to multiple fields when manipulating files. An unauthenticated, remote attacker can exploit this to have an unspecified impact on integrity. Note that a site is only affected by this issue if it has the
RESTful Web Services (rest) module enabled, the file REST resource is enabled and allows PATCH requests, and the attacker can get or register a user account on the site with permissions to upload files and to modify the file resource. (CVE-2017-6921)

- An information disclosure vulnerability exists due to a failure to ensure that private files that have been uploaded by an anonymous user but not permanently attached to content on the site are only visible to the anonymous user who uploaded them instead of all anonymous users. An unauthenticated
, remote attacker can exploit this to disclose the files of other anonymous users. (CVE-2017-6922)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to Drupal version 8.3.4 or latest.

See Also

https://www.drupal.org/forum/newsletters/security-advisories-for-drupal-core/2017-06-21/drupal-core-multiple

https://www.drupal.org/project/drupal/releases/8.3.4

Plugin Details

Severity: Critical

ID: 98558

Type: remote

Published: 2018/11/05

Updated: 2018/11/05

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2017/06/21

Vulnerability Publication Date: 2017/06/21

Reference Information

CVE: CVE-2017-6920, CVE-2017-6921, CVE-2017-6922

BID: 99211, 99219, 99222