Magento 2.1.x < 2.1.17 / 2.2.x < 2.2.8 / 2.3.x < 2.3.1 SQL Injection

High Web Application Scanning Plugin ID 98531

Synopsis

Magento 2.1.x < 2.1.17 / 2.2.x < 2.2.8 / 2.3.x < 2.3.1 SQL Injection

Description

The Magento application running on the remote web server is affected by a SQL injection vulnerability due to failing to properly sanitize the user-supplied 'from' and 'to' inputs to the 'prepareSqlCondition' function of the '\Magento\Framework\DB\Adapter\Pdo\Mysql' class. An unauthenticated, remote attacker can exploit this to execute arbitrary SQL statements against the back-end database, leading to the execution of arbitrary code, manipulation of data, or disclosure of sensitive information.

Note: This has been detected using an active check and should be remediated immediately.

Solution

Apply the appropriate patch according to the vendor advisory.

See Also

https://magento.com/security/patches/magento-2.3.1-2.2.8-and-2.1.17-security-update

https://www.ambionics.io/blog/magento-sqli

Plugin Details

Severity: High

ID: 98531

Type: remote

Published: 2019/04/10

Updated: 2019/04/10

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 10

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:magento:magento:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2019/03/26

Vulnerability Publication Date: 2019/03/26

Reference Information

CWE: 89

WASC: SQL Injection

OWASP: 2013-A1, 2017-A1