Apache Tomcat JK Connector 1.2.x < 1.2.46 Access Control Bypass

high Web Application Scanning Plugin ID 98522
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


Apache Tomcat JK Connector 1.2.x < 1.2.46 Access Control Bypass


The version of Apache Tomcat JK Connector (mod_jk) installed on the remote host is version 1.2.x prior to 1.2.46. It is, therefore, affected by an access control bypass vulnerability due to improper handling of the Apache web server specific code that normalised the requested path before matching it to the URI-worker map.

Note that the scanner has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat JK Connector version 1.2.46 or later.

See Also



Plugin Details

Severity: High

ID: 98522

Type: remote

Published: 3/25/2019

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information


Risk Factor: Medium

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N


Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat_connectors:*:*:*:*:*:*:*:*

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/31/2018

Vulnerability Publication Date: 10/31/2018

Reference Information

CVE: CVE-2018-11759