Joomla! 3.0.x < 3.8.0 Multiple Vulnerabilities

Medium Web Application Scanning Plugin ID 98458

Synopsis

Joomla! 3.0.x < 3.8.0 Multiple Vulnerabilities

Description

According to its self-reported version number, the detected Joomla! application is affected by multiple vulnerabilities :

- A flaw exists related to SQL query handling that allows disclosure of article introduction text when such articles are in the archived state. Note that only versions 3.7.0 through 3.7.5 are affected by this flaw. (CVE-2017-14595)

- An input-validation flaw exists in the LDAP authentication plugin that allows disclosure of usernames and passwords. Note that Joomla! must be configured for LDAP authentication to be affected. (CVE-2017-14596)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to Joomla! version 3.8.0 or latest.

See Also

https://www.joomla.org/announcements/release-news/5713-joomla-3-8-0-release.html

https://developer.joomla.org/security-centre/711-20170902-core-ldap-information-disclosure

Plugin Details

Severity: Medium

ID: 98458

Type: remote

Published: 2018/11/05

Updated: 2018/11/05

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2017/09/19

Vulnerability Publication Date: 2017/09/19

Reference Information

CVE: CVE-2017-14595, CVE-2017-14596

BID: 100898, 100900