Joomla! 3.1.x < 3.8.0 Multiple Vulnerabilities

Medium Web Application Scanning Plugin ID 98457


Joomla! 3.1.x < 3.8.0 Multiple Vulnerabilities


According to its self-reported version number, the detected Joomla! application is affected by multiple vulnerabilities :

- A flaw exists related to SQL query handling that allows disclosure of article introduction text when such articles are in the archived state. Note that only versions 3.7.0 through 3.7.5 are affected by this flaw. (CVE-2017-14595)

- An input-validation flaw exists in the LDAP authentication plugin that allows disclosure of usernames and passwords. Note that Joomla! must be configured for LDAP authentication to be affected. (CVE-2017-14596)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Update to Joomla! version 3.8.0 or latest.

See Also

Plugin Details

Severity: Medium

ID: 98457

Type: remote

Published: 2018/11/05

Updated: 2018/11/05

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2017/09/19

Vulnerability Publication Date: 2017/09/19

Reference Information

CVE: CVE-2017-14595, CVE-2017-14596

BID: 100898, 100900

CWE: 19, 90

WASC: Improper Input Handling, LDAP Injection

OWASP: 2010-A1, 2010-A4, 2013-A1, 2013-A4, 2013-A9, 2017-A1, 2017-A5, 2017-A9