jQuery UI < 1.12.0 Cross-Site Scripting

medium Web Application Scanning Plugin ID 98393
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

jQuery UI < 1.12.0 Cross-Site Scripting

Description

According to its self-reported version number, jQuery UI is prior to 1.12.0. Therefore, it may be affected by a Cross-Site Scripting (XSS) vulnerability due to improper escaping of the closeText property.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to jQuery UI version 1.12.0 or later.

See Also

https://github.com/jquery/api.jqueryui.com/issues/281

Plugin Details

Severity: Medium

ID: 98393

Type: remote

Published: 3/15/2019

Updated: 4/9/2021

Scan Template: api, scan, pci

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:jquery:jquery_ui:*:*:*:*:*:*:*:*

Patch Publication Date: 3/15/2017

Vulnerability Publication Date: 3/15/2017

Reference Information

CVE: CVE-2016-7103