WordPress 4.1.x < 4.1.25 Multiple Vulnerabilities

critical Web Application Scanning Plugin ID 98379

Language:

Synopsis

WordPress 4.1.x < 4.1.25 Multiple Vulnerabilities

Description

According to its self-reported version number, the detected WordPress application is affected by multiple vulnerabilities :

- Authors could alter meta data to delete files that they weren’t authorized to.

- Authors could create posts of unauthorized types with specially crafted input.

- Contributors could craft meta data in a way that resulted in PHP object injection.

- Contributors could edit new comments from higher-privileged users, potentially leading to a cross-site scripting.

- User activation screen could be indexed by search engines leading to exposure of sensitive information.

- Authors on Apache-hosted sites could upload specifically crafted files that bypass MIME verification, leading to a cross-site scripting.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to WordPress version 4.1.25 or latest.

See Also

https://wordpress.org/news/2018/12/wordpress-5-0-1-security-release/

https://wordpress.org/support/wordpress-version/version-4-1-25/

Plugin Details

Severity: Critical

ID: 98379

Type: remote

Published: 12/17/2018

Updated: 10/7/2021

Scan Template: pci, api, scan

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2018-20148

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2018-20148

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 12/14/2018

Vulnerability Publication Date: 12/14/2018

Reference Information

CVE: CVE-2018-20147, CVE-2018-20148, CVE-2018-20149, CVE-2018-20150, CVE-2018-20151, CVE-2018-20152, CVE-2018-20153

CWE: 200, 79, 284, 74

WASC: Cross-Site Scripting, Information Leakage, Improper Input Handling, Insufficient Authorization

OWASP: 2010-A2, 2013-A3, 2013-A9, 2017-A7, 2017-A9, 2017-A6, 2013-A5, 2010-A6, 2017-A5, 2010-A1, 2013-A1, 2017-A1, 2010-A8, 2013-A7, 2021-A6, 2021-A1, 2021-A3

OWASP API: 2019-API7, 2019-API8

HIPAA: 164.306(a)(1), 164.306(a)(2), 164.312(a)(1), 164.312(a)(2)(i)

DISA STIG: APSC-DV-002630, APSC-DV-000460, APSC-DV-002560, APSC-DV-002490

OWASP ASVS: 4.0.2-14.2.1, 4.0.2-8.3.4, 4.0.2-1.4.2, 4.0.2-5.3.3, 4.0.2-5.2.5

PCI-DSS: 3.2-6.2, 3.2-6.5.8, 3.2-6.5.7, 3.2-6.5.1

ISO: 27001-A.14.2.5, 27001-A.13.1.1, 27001-A.14.1.2, 27001-A.14.1.3, 27001-A.18.1.3, 27001-A.6.2.2, 27001-A.9.1.2, 27001-A.9.4.1, 27001-A.9.4.4, 27001-A.9.4.5

CAPEC: 116, 13, 169, 22, 224, 285, 287, 290, 291, 292, 293, 294, 295, 296, 297, 298, 299, 300, 301, 302, 303, 304, 305, 306, 307, 308, 309, 310, 312, 313, 317, 318, 319, 320, 321, 322, 323, 324, 325, 326, 327, 328, 329, 330, 472, 497, 508, 573, 574, 575, 576, 577, 59, 60, 616, 643, 646, 651, 79, 64, 76, 78, 19, 441, 478, 479, 502, 503, 536, 546, 550, 551, 552, 556, 558, 562, 563, 564, 578, 10, 14, 209, 24, 42, 45, 46, 47, 588, 591, 592, 63, 8, 85, 9, 101, 108, 120, 135, 250, 267, 28, 3, 43, 52, 53, 67, 7, 71, 72, 80, 83, 273, 34, 51, 6, 84

NIST: sp800_53-CM-6b, sp800_53-SI-10, sp800_53-AC-3, sp800_53-SI-15