WordPress 4.0.x < 4.0.20 Multiple Vulnerabilities

High Web Application Scanning Plugin ID 98314

Synopsis

WordPress 4.0.x < 4.0.20 Multiple Vulnerabilities

Description

According to its self-reported version number, the detected WordPress application is affected by multiple vulnerabilities :

- Weak MD5-based password hashing algorithm, which makes it easier for attackers to determine cleartext values by leveraging access to the hash values.

- When domain-based flashmediaelement.swf sandboxing is not used, allows remote attackers to conduct cross-domain Flash injection (XSF) attacks by leveraging code contained within the wp-includes/js/mediaelement/flashmediaelement.swf file.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to WordPress version 4.0.20 or latest.

See Also

https://wordpress.org/news/2017/10/wordpress-4-8-3-security-release/

https://codex.wordpress.org/Version_4.0.20

Plugin Details

Severity: High

ID: 98314

Type: remote

Published: 2018/11/05

Updated: 2018/11/05

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2017/10/31

Vulnerability Publication Date: 2017/10/31

Reference Information

CVE: CVE-2012-6707, CVE-2016-9263, CVE-2017-14723, CVE-2017-16510

BID: 101638