WordPress 4.7.x < 4.7.7 Multiple Vulnerabilities

High Web Application Scanning Plugin ID 98307


WordPress 4.7.x < 4.7.7 Multiple Vulnerabilities


According to its self-reported version number, the detected WordPress application is affected by multiple vulnerabilities :

- Weak MD5-based password hashing algorithm, which makes it easier for attackers to determine cleartext values by leveraging access to the hash values.

- When domain-based flashmediaelement.swf sandboxing is not used, allows remote attackers to conduct cross-domain Flash injection (XSF) attacks by leveraging code contained within the wp-includes/js/mediaelement/flashmediaelement.swf file.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Update to WordPress version 4.7.7 or latest.

See Also



Plugin Details

Severity: High

ID: 98307

Type: remote

Published: 2018/11/05

Updated: 2018/11/05

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2017/10/31

Vulnerability Publication Date: 2017/10/31

Reference Information

CVE: CVE-2012-6707, CVE-2016-9263, CVE-2017-14723, CVE-2017-16510

BID: 101638

CWE: 20, 326, 89

WASC: Improper Input Handling, Application Misconfiguration, SQL Injection

OWASP: 2010-A1, 2010-A4, 2010-A7, 2013-A1, 2013-A4, 2013-A6, 2013-A9, 2017-A1, 2017-A3, 2017-A5, 2017-A9