Drupal < 7.58 / 8.x < 8.3.9 / 8.4.x < 8.4.6 / 8.5.x < 8.5.1 Remote Code Execution

Critical Web Application Scanning Plugin ID 98216

Synopsis

Drupal < 7.58 / 8.x < 8.3.9 / 8.4.x < 8.4.6 / 8.5.x < 8.5.1 Remote Code Execution

Description

A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially
allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being
completely compromised.

Note: This has been detected using an active check and should be remediated immediately.

Solution

Upgrade to Drupal version 7.58 / 8.3.9 / 8.4.6 / 8.5.1 or later.

See Also

https://www.drupal.org/sa-core-2018-002

https://groups.drupal.org/security/faq-2018-002

Plugin Details

Severity: Critical

ID: 98216

Type: remote

Published: 2018/05/22

Updated: 2018/05/22

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

Exploit Available: true

Patch Publication Date: 2018/03/28

Vulnerability Publication Date: 2018/03/29

Reference Information

CVE: CVE-2018-7600

BID: 103534