Next.js 10.0.0 < 14.2.32 Multiple Vulnerabilities

high Web App Scanning Plugin ID 115779

Synopsis

Next.js 10.0.0 < 14.2.32 Multiple Vulnerabilities

Description

The version of Next.js installed on the remote host is prior to 14.2.32 or 15.x prior to 15.4.7. It is, therefore, affected by multiple vulnerabilities:

- A Server-Side Request Forgery vulnerability in self-hosted applications when request headers are directly passed into NextResponse.next() in Middleware. This issue is fixed in versions 14.2.32 and 15.4.7. (CVE-2025-57822)

- A content injection vulnerability in the Image Optimization API. This issue is fixed in versions 14.2.31 and 15.4.5. (CVE-2025-55173)

- A cache key confusion vulnerability in the Image Optimization API routes. This issue is fixed in versions 14.2.31 and 15.4.5. (CVE-2025-57752)

Note that the scanner has not attempted to exploit these issues but has instead relied only on application's self-reported version number.

Solution

Upgrade to Next.js version 14.2.32 or later.

See Also

https://github.com/vercel/next.js/security/advisories/GHSA-4342-x723-ch2f

https://github.com/vercel/next.js/security/advisories/GHSA-g5qg-72qw-gw5v

https://github.com/vercel/next.js/security/advisories/GHSA-xv57-4mr9-wg8v

Plugin Details

Severity: High

ID: 115779

Type: Version Based

Published: 11/6/2026

Updated: 11/6/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Low

Score: 3.5

Percentile: 52.01

CVSS v2

Risk Factor: High

Base Score: 8.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:P/A:N

CVSS Score Source: CVE-2025-57822

CVSS v3

Risk Factor: High

Base Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

CVSS Score Source: CVE-2025-57822

Vulnerability Information

CPE: cpe:2.3:a:vercel:next.js:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 8/28/2025

Reference Information

CVE: CVE-2025-55173, CVE-2025-57752, CVE-2025-57822