Next.js 16.0.x < 16.2.6 Middleware Authorization Bypass

high Web App Scanning Plugin ID 115734

Synopsis

Next.js 16.0.x < 16.2.6 Middleware Authorization Bypass

Description

The version of Next.js installed on the remote host is 15.2.0 prior to 15.5.18 or 16.0.0 prior to 16.2.6. It is, therefore, affected by a Middleware / Proxy bypass in App Router applications via segment-prefetch routes, as the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack.

Note that the scanner has not attempted to exploit this issue but has instead relied only on application's self-reported version number.

Solution

Upgrade to Next.js version 16.2.6 or later.

See Also

https://github.com/vercel/next.js/security/advisories/GHSA-267c-6grr-h53f

https://github.com/vercel/next.js/security/advisories/GHSA-26hh-7cqf-hhc6

Plugin Details

Severity: High

ID: 115734

Type: Version Based

Published: 10/28/2026

Updated: 10/28/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.61

CVSS v2

Risk Factor: High

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2026-45109

CVSS v3

Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

CVSS Score Source: CVE-2026-45109

Vulnerability Information

CPE: cpe:2.3:a:vercel:next.js:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 5/10/2026

Reference Information

CVE: CVE-2026-45109