Elementor Plugin for WordPress < 3.29.1 Authenticated Stored Cross-Site Scripting

medium Web App Scanning Plugin ID 115726

Synopsis

Elementor Plugin for WordPress < 3.29.1 Authenticated Stored Cross-Site Scripting

Description

The WordPress Elementor Plugin installed on the remote host is affected by an authenticated (Contributor+) Stored Cross-Site Scripting via the 'elementor-element' shortcode due to insufficient input sanitization and output escaping on user supplied attributes. This only impacts sites with 'Element Caching' enabled.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Elementor Plugin for WordPress 3.29.1 or later.

See Also

https://wordpress.org/plugins/elementor/

Plugin Details

Severity: Medium

ID: 115726

Type: Version Based

Published: 10/28/2026

Updated: 10/28/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Low

Score: 2.3

Percentile: 8.67

CVSS v2

Risk Factor: Medium

Base Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

CVSS Score Source: CVE-2025-3075

CVSS v3

Risk Factor: Medium

Base Score: 5.4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

CVSS Score Source: CVE-2025-3075

Vulnerability Information

CPE: cpe:2.3:a:elementor:website_builder:*:*:*:*:free:wordpress:*:*

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 7/28/2025

Reference Information

CVE: CVE-2025-3075