Beaver Builder Plugin for WordPress < 2.9.4.2 Arbitrary Code Execution

high Web App Scanning Plugin ID 115723

Synopsis

Beaver Builder Plugin for WordPress < 2.9.4.2 Arbitrary Code Execution

Description

The WordPress Beaver Builder Plugin installed on the remote host is affected by an Arbitrary Code Execution due to improper control of generation of code (Code Injection).

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Beaver Builder Plugin for WordPress 2.9.4.2 or later.

See Also

https://wordpress.org/plugins/beaver-builder-lite-version/

Plugin Details

Severity: High

ID: 115723

Type: Version Based

Published: 10/28/2026

Updated: 10/28/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 57.49

CVSS v2

Risk Factor: High

Base Score: 7.1

Vector: CVSS2#AV:N/AC:H/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2025-69319

CVSS v3

Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2025-69319

Vulnerability Information

CPE: cpe:2.3:a:fastlinemedia:beaver_builder:*:*:*:*:lite:wordpress:*:*

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 1/21/2026

Reference Information

CVE: CVE-2025-69319