Atlassian Confluence 7.20.x < 8.5.5 Cross-Site Scripting

high Web App Scanning Plugin ID 114222


Atlassian Confluence 7.20.x < 8.5.5 Cross-Site Scripting


According to its self-reported version number, the Atlassian Confluence application running on the remote host is prior to 7.19.18, 7.20.x prior to 8.5.5 or 8.7.x prior to 8.7.2. It is, therefore, affected by a stored Cross-Site Scripting (XSS) vulnerability.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Atlassian Confluence version 8.5.5 or later.

See Also

Plugin Details

Severity: High

ID: 114222

Type: remote

Published: 2/27/2024

Updated: 2/27/2024

Scan Template: api, basic, full, pci, scan

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: Low

Base Score: 3.5

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

CVSS Score Source: CVE-2024-21678


Risk Factor: High

Base Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N

CVSS Score Source: CVE-2024-21678

Vulnerability Information

CPE: cpe:2.3:a:atlassian:confluence:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 2/20/2024

Vulnerability Publication Date: 2/20/2024

Reference Information

CVE: CVE-2024-21678