Joomla! 5.x < 5.0.3 Multiple Vulnerabilities

high Web App Scanning Plugin ID 114217


Joomla! 5.x < 5.0.3 Multiple Vulnerabilities


According to its self-reported version, the instance of Joomla! running on the remote web server is 1.5.x prior to 4.4.3 or 5.x prior to 5.0.3. It is, therefore, affected by multiple vulnerabilities.

- An insufficient session expiration in MFA management views. (CVE-2024-21722)

- An open redirect in installation application. (CVE-2024-21723)

- A Cross-Site Scripting (XSS) in media selection fields. (CVE-2024-21724)

- A Cross-Site Scripting (XSS) in mail address outputs. (CVE-2024-21725)

- An inadequate content filtering within the filter code. (CVE-2024-21726)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Update to Joomla! version 5.0.3 or latest.

See Also

Plugin Details

Severity: High

ID: 114217

Type: remote

Published: 2/21/2024

Updated: 2/21/2024

Scan Template: api, basic, full, pci, scan

Risk Information


Risk Factor: Medium

Score: 5.7


Risk Factor: Medium

Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2024-21723


Risk Factor: High

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2024-21722

Vulnerability Information

CPE: cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 2/20/2024

Vulnerability Publication Date: 2/20/2024

Reference Information

CVE: CVE-2024-21722, CVE-2024-21723, CVE-2024-21724, CVE-2024-21725, CVE-2024-21726