Nginx 1.25.x < 1.25.4 Multiple Vulnerabilities

high Web App Scanning Plugin ID 114207


Nginx 1.25.x < 1.25.4 Multiple Vulnerabilities


According to its Server response header, the installed version of nginx is 1.25.x prior to 1.25.4. It is, therefore, affected by the following issues :

- A NULL pointer dereference in HTTP/3. (CVE-2024-24989)

- A Use-after-free in HTTP/3. (CVE-2024-24990)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to nginx version 1.25.4 or later.

See Also

Plugin Details

Severity: High

ID: 114207

Type: remote

Published: 2/19/2024

Updated: 2/19/2024

Scan Template: api, basic, full, pci, scan

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: High

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2024-24989


Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVSS Score Source: CVE-2024-24989

Vulnerability Information

CPE: cpe:2.3:a:f5:nginx:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 2/14/2024

Vulnerability Publication Date: 2/14/2024

Reference Information

CVE: CVE-2024-24989, CVE-2024-24990