WS_FTP Server Remote Code Execution

high Web App Scanning Plugin ID 114114

Language:

Synopsis

WS_FTP Server Remote Code Execution

Description

In WS_FTP Server versions prior to 8.7.4 and 8.8.2, a pre-authenticated attacker could leverage a .NET deserialization vulnerability in the Ad Hoc Transfer module to execute remote commands on the underlying WS_FTP Server operating system.

Plugin Details

Severity: High

ID: 114114

Type: remote

Published: 12/1/2023

Updated: 12/1/2023

Scan Template: basic, full, pci, scan

Risk Information

VPR

Risk Factor: Critical

Score: 9.5

CVSS v2

Risk Factor: High

Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2023-40044

CVSS v3

Risk Factor: High

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2023-40044

Reference Information

CVE: CVE-2023-40044