HandlebarsJS < 3.0.8 Arbitrary Code Execution

high Web App Scanning Plugin ID 114095

Language:

Synopsis

HandlebarsJS < 3.0.8 Arbitrary Code Execution

Description

According to its self-reported version number, HandlebarsJS on the remote server is prior to 3.0.8 or 4.x prior to 4.5.3. Therefore, it may be affected by a arbitrary code execution vulnerability permitting attackers to submit templates that execute aribtrary Javascript either server-side on a server processing Handlebars templates, or in a victims browser.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to HandlebarsJS version 3.0.8 or later.

See Also

https://www.npmjs.com/advisories/1324

Plugin Details

Severity: High

ID: 114095

Type: remote

Published: 10/24/2023

Updated: 10/25/2023

Scan Template: api, basic, full, pci, scan

Risk Information

VPR

Risk Factor: Medium

Score: 6.6

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2019-20920

CVSS v3

Risk Factor: High

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:L

CVSS Score Source: CVE-2019-20920

Vulnerability Information

CPE: cpe:2.3:a:handlebarsjs:handlebars:-:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 10/18/2019

Vulnerability Publication Date: 9/30/2020

Reference Information

CVE: CVE-2019-20920