Apache 2.4.x < 2.4.58 Multiple Vulnerabilities

high Web App Scanning Plugin ID 114090



Apache 2.4.x < 2.4.58 Multiple Vulnerabilities


According to its banner, the version of Apache running on the remote host is 2.4.x prior to 2.4.58. It is, therefore, affected by multiple vulnerabilities:

- Out-of-bounds read vulnerability in mod_macro of Apache HTTP Server. (CVE-2023-31122)

- An attacker, opening a HTTP/2 connection with an initial window size of 0, was able to block handling of that connection indefinitely in Apache HTTP Server. This could be used to exhaust worker resources in the server, similar to the well known slow loris attack pattern. (CVE-2023-43622)

- A client could send new requests and resets, keeping the connection busy and open and causing the memory footprint to keep on growing. On connection close, all resources were reclaimed, but the process might run out of memory before that. (CVE-2023-45802) Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache version 2.4.58 or later.

See Also



Plugin Details

Severity: High

ID: 114090

Type: remote

Published: 10/20/2023

Updated: 11/15/2023

Scan Template: api, basic, full, pci, scan

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: High

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2023-31122


Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVSS Score Source: CVE-2023-31122

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 10/19/2023

Vulnerability Publication Date: 10/19/2023

Reference Information

CVE: CVE-2023-31122, CVE-2023-43622, CVE-2023-45802