MediaWiki 1.37.x < 1.37.1 Multiple Vulnerabilities

high Web App Scanning Plugin ID 113992



MediaWiki 1.37.x < 1.37.1 Multiple Vulnerabilities


According to its self-reported version number, the instance of MediaWiki hosted on the remote web server is prior to 1.35.5, 1.36.x prior to 1.36.3 or 1.37 prior to 1.37.1, It is, therefore, affected by a number of vulnerabilities as follows.

- A vulnerability in the date validation functions of Special:CheckUserLog enabling XSS attacks.

- A flaw with length validation routines in Language Name Search in api.php leading to a denial of service when a very long key is used in the search.

- A flaw in MassEditRegex whereby it does not correctly check for CSRF tokens making it vulnerable to attack.

- A vulnerability in WikibaseMediaInfo's handling of caption fields enabling XSS attacks.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to MediaWiki version 1.37.1 or later.

See Also

Plugin Details

Severity: High

ID: 113992

Type: remote

Published: 8/7/2023

Updated: 8/9/2023

Scan Template: api, basic, full, pci, scan

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: Medium

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2021-46147


Risk Factor: High

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2021-46147

Vulnerability Information

CPE: cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 1/13/2022

Vulnerability Publication Date: 1/10/2022

Reference Information

CVE: CVE-2021-46146, CVE-2021-46147, CVE-2021-46149, CVE-2021-46150