phpMyAdmin 5.0.x < 5.0.1 SQL Injection

high Web Application Scanning Plugin ID 113300

Synopsis

phpMyAdmin 5.0.x < 5.0.1 SQL Injection

Description

The version of phpMyAdmin installed on the remote host does not correcty deal with malicious sql injected in place of a valid username when creating queries on the user accounts page leading to a SQL injection vulnerability. Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to phpMyAdmin version 5.0.1 or later.

See Also

https://www.phpmyadmin.net/security/PMASA-2020-1/

Plugin Details

Severity: High

ID: 113300

Type: remote

Published: 7/11/2022

Updated: 7/11/2022

Scan Template: pci, api, scan

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS Score Source: CVE-2020-5504

CVSS v3

Risk Factor: High

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2020-5504

Vulnerability Information

CPE: cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 1/5/2020

Vulnerability Publication Date: 1/5/2020

Reference Information

CVE: CVE-2020-5504