WordPress 4.0.x < 4.0.34 Multiple Vulnerabilities

high Web Application Scanning Plugin ID 113095

Language:

Synopsis

WordPress 4.0.x < 4.0.34 Multiple Vulnerabilities

Description

According to its self-reported version number, the detected WordPress application is affected by multiple vulnerabilities :

- A stored Cross-Site Scripting (XSS) vulnerability through post slugs.

- An object injection vulnerability in some multisite installations.

- A SQL injection vulnerability in WP_Query.

- A SQL injection vulnerability in WP_Meta_Query.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to WordPress version 4.0.34 or latest.

See Also

https://wordpress.org/news/2022/01/wordpress-5-8-3-security-release/

https://wordpress.org/support/wordpress-version/version-4-0-34/

Plugin Details

Severity: High

ID: 113095

Type: remote

Published: 1/7/2022

Updated: 1/7/2022

Scan Template: pci, api, scan

Risk Information

VPR

Risk Factor: High

Score: 8.4

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS Score Source: Tenable

CVSS v3

Risk Factor: High

Base Score: 7.2

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: Tenable

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 1/6/2022

Vulnerability Publication Date: 1/6/2022

Reference Information