PHP 7.3.x < 7.3.32 Privilege Escalation

high Web Application Scanning Plugin ID 113040



PHP 7.3.x < 7.3.32 Privilege Escalation


According to its self-reported version number, the version of PHP running on the remote web server is 7.3.x priori to 7.3.32, 7.4.x prior to 7.4.25 or 8.0.x prior to 8.0.12. It is, therefore, affected by a privilege escalation vulnerability. The root FPM process can be forced to read/write at arbitrary locations using pointers located in the SHM, leading to a privilege escalation from www-data to root.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 7.3.32 or later.

See Also

Plugin Details

Severity: High

ID: 113040

Type: remote

Published: 10/29/2021

Updated: 10/26/2022

Scan Template: pci, api, scan

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Medium

Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2021-21703


Risk Factor: High

Base Score: 7

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2021-21703

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 10/21/2021

Vulnerability Publication Date: 10/21/2021

Reference Information

CVE: CVE-2021-21703