PHP 7.4.x < 7.4.25 Privilege Escalation

high Web Application Scanning Plugin ID 113039

Language:

Synopsis

PHP 7.4.x < 7.4.25 Privilege Escalation

Description

According to its self-reported version number, the version of PHP running on the remote web server is 7.3.x priori to 7.3.32, 7.4.x prior to 7.4.25 or 8.0.x prior to 8.0.12. It is, therefore, affected by a privilege escalation vulnerability. The root FPM process can be forced to read/write at arbitrary locations using pointers located in the SHM, leading to a privilege escalation from www-data to root.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.4.25 or later.

See Also

https://www.php.net/ChangeLog-7.php#7.4.25

Plugin Details

Severity: High

ID: 113039

Type: remote

Published: 10/27/2021

Updated: 10/26/2022

Scan Template: pci, api, scan

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2021-21703

CVSS v3

Risk Factor: High

Base Score: 7

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2021-21703

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 10/21/2021

Vulnerability Publication Date: 10/21/2021

Reference Information

CVE: CVE-2021-21703