Apache 2.4.49 < 2.4.51 Path Traversal

critical Web Application Scanning Plugin ID 113015

Synopsis

Apache 2.4.49 < 2.4.51 Path Traversal

Description

According to its banner, the version of Apache running on the remote host is 2.4.49 or 2.4.50. It is, therefore, affected by a path traversal vulnerability. The fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.51 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.51

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.51

Plugin Details

Severity: Critical

ID: 113015

Type: remote

Published: 10/8/2021

Updated: 10/18/2021

Scan Template: scan, pci, api

Risk Information

CVSS Score Source: CVE-2021-42013

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 10/7/2021

Vulnerability Publication Date: 10/7/2021

Reference Information

CVE: CVE-2021-42013