Apache 2.4.49 < 2.4.50 Multiple Vulnerabilities

high Web Application Scanning Plugin ID 113014

Synopsis

Apache 2.4.49 < 2.4.50 Multiple Vulnerabilities

Description

According to its banner, the version of Apache running on the remote host is 2.4.49. It is, therefore, affected by multiple vulnerabilities:

- While fuzzing the 2.4.49 httpd, a new null pointer dereference was detected during HTTP/2 request processing, allowing an external source to DoS the server. This requires a specially crafted request. The vulnerability was recently introduced in version 2.4.49. No exploit is known to the project. (CVE-2021-41524)

- A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the expected document root. If files outside of the document root are not protected by require all denied these requests can succeed. Additionally this flaw could leak the source of interpreted files like CGI scripts. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. (CVE-2021-41773) Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.50 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.50

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.50

Plugin Details

Severity: High

ID: 113014

Type: remote

Published: 10/6/2021

Updated: 10/15/2021

Scan Template: scan, pci

Risk Information

CVSS Score Source: CVE-2021-41524

CVSS v2

Risk Factor: Medium

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3

Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 10/4/2021

Vulnerability Publication Date: 10/4/2021

Reference Information

CVE: CVE-2021-41524, CVE-2021-41773