Underscore.js 1.3.2 < 1.12.1 Arbitrary Code Injection

high Web Application Scanning Plugin ID 112982

Language:

Synopsis

Underscore.js 1.3.2 < 1.12.1 Arbitrary Code Injection

Description

According to its self-reported version number, Underscore.js is 1.3.2 prior to 1.12.1 or 1.13.x prior to 1.13.0-2. Therefore, it may be affected by an arbitrary code injection via the template function when the variable option is taken from _.templateSettings.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Underscore.js version 1.12.1 or later.

See Also

https://github.com/jashkenas/underscore/commit/4c73526d43838ad6ab43a6134728776632adeb66

Plugin Details

Severity: High

ID: 112982

Type: remote

Published: 9/23/2021

Updated: 10/26/2022

Scan Template: scan, pci

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS Score Source: CVE-2021-23358

CVSS v3

Risk Factor: High

Base Score: 7.2

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2021-23358

Vulnerability Information

CPE: cpe:2.3:a:underscorejs:underscore:*:*:*:*:*:node.js:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 3/2/2021

Vulnerability Publication Date: 3/2/2021

Reference Information

CVE: CVE-2021-23358