Drupal 9.1.x < 9.1.11 Third-Party Library Vulnerability

high Web Application Scanning Plugin ID 112917
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Drupal 9.1.x < 9.1.11 Third-Party Library Vulnerability

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 7.0.x prior to 7.82, 8.9.x prior to 8.9.17, 9.1.x prior to 9.1.11 or 9.2.x prior to 9.2.2. It is, therefore, affected by a vulnerability due to the PEAR Archive_Tar library used by Drupal.

The Drupal project uses the pear Archive_Tar library, which has released a security update that impacts Drupal.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to Drupal version 9.1.11 or latest.

See Also

https://www.drupal.org/sa-core-2021-004

https://www.drupal.org/project/drupal/releases/9.1.11

Plugin Details

Severity: High

ID: 112917

Type: remote

Published: 7/26/2021

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS Score Source: CVE-2021-32610

CVSS v2

Risk Factor: Low

Base Score: 3.6

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:N

CVSS v3

Risk Factor: High

Base Score: 7.1

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Vulnerability Information

CPE: cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 7/21/2021

Vulnerability Publication Date: 7/21/2021

Reference Information

CVE: CVE-2021-32610

CWE: 20

WASC: Improper Input Handling

OWASP: 2010-A4, 2013-A4, 2013-A9, 2017-A5, 2017-A9, 2021-A3, 2021-A6

OWASP API: 2019-API7