X-Cart 4.4.0 < 4.7.11 Multiple Vulnerabilities

critical Web Application Scanning Plugin ID 112884

Language:

Synopsis

X-Cart 4.4.0 < 4.7.11 Multiple Vulnerabilities

Description

According to the self-reported version in its response header, the version of X-Cart hosted on the remote web server is 4.4.0 < 4.7.10. It is, therefore, affected by multiples vulnerabilities :

- A SQL injection vulnerability.

- A Cross-Site Scripting (XSS) against embedded jQuery component.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to X-Cart version 4.7.11 or later.

See Also

https://www.x-cart.com/blog/x-cart-v4-7-11-and-security-patches.html

Plugin Details

Severity: Critical

ID: 112884

Type: remote

Published: 7/8/2021

Updated: 10/7/2021

Scan Template: pci, scan

Risk Information

VPR

Risk Factor: High

Score: 7.7

CVSS v2

Risk Factor: High

Base Score: 9.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:P/A:C

CVSS Score Source: Tenable

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

CVSS Score Source: Tenable

Vulnerability Information

CPE: cpe:2.3:a:qualiteam:xcart:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 4/25/2019

Vulnerability Publication Date: 4/25/2019

Reference Information